Synology – Kopieren von Bildern sehr langsam

(C) 107er BLOG

Das kopieren von Bildern von einem Windows 10 Computer auf das Synology NAS ist extrem langsam. Was kann man dagegen machen?

Setup

Das Synology NAS befindet sich in einem Domain Netzwerk, und der PC und das NAS ist mit einem Gigabit Switch verbunden. Als Domain Controller wird ein weiteres Synology NAS eingesetzt.

Problem

Das kopieren von einer großen Anzahl an Bildern (JPG, CR2) oder kleineren Dateien (Grösse zwischen 800KB und 8MB) ist extrem langsam.  Obwohl PC und NAS am selben Gigabit Switch hängen, sind die Übertragungsraten nur zwischen 200KB – 5 MB und das Kopieren dauert unendlich lange!

Wenn man hingegen Videos von 2 oder 3 GB kopiert, also wenige große Dateien, bekommt man ohne Probleme eine Übertragungsrate zwischen 60 – 80 MB/Sekunde zu stande.

Lösungsversuche

Das Problem der langsamen Übertragungsraten widmet Synology eine ganzes Kapitel, und zwar “Was kann ich tun, wenn die Dateiübertragung über Windows (SMB/CIFS) langsam ist?“. Es wird folgendes geraten …

  • Regeln in der Datenflusssteuerung deaktiveren, die SMB oder CIFS betreffen
  • Server-Signierung deaktivieren bei Domänenoptionen
  • Daten-Prüfsumme bei Freigegebenen Ordnern deaktivieren
  • SMB2 mit Large MTU als Mindest SMB Protokoll und Opportunistic Locking und SM2 Lease aktivieren
  • Debug Protokolle deaktiveren

Leider brachte keine Einstellung den erwünschten Erfolg!

Es gibt in den weiten des Internets noch weitere Lösungsvorschläge, die leider auch keinen wirklichen Erfolg gebracht haben.

  • IPv6 auf dem NAS deaktivieren
  • Clear SMB Cache Button drücken

Einfache Lösung große Wirkung

Die Lösung die schlussendlich umgesetzt wurde, habe ich in einem Forum gefunden. Dort bin ich über folgenden Eintrag gestolpert:

I am observing a similar issue though not quite as severe. After doing a lot of searching and testing the only thing that I found that using the NAS IP address instead of it’s DNS address helped considerably. This improved the transfer rate by a factor of 5.6.

Das bedeutet nichts anderes als, wenn man im Windows Explorer statt dem DNS Namen, die IP-Adresse oder NETBIOS Namen des Servers angibt erhöht sich die Übertragungsrate um ein Vielfaches! Bei einem kurzen Test kamen danach Übertragungsraten zwischen 40 – 60 MB/Sekunde zu Stande.

Also anstatt \\titan.domain.loc\ sollte man folgendes eingeben

  • \\titan\ oder(Netbios Name)
  • \\192.168.0.40\ (IP-Adresse)

Was jetzt genau die Ursache ist, und ob man das Problem noch eleganter lösen kann, bleibt jetzt einmal unbeantwortet. Die Lösung wurde als gut befunden und es wurden keine weiteren Schritte für die Ursachenforschung gesetzt.

Quellen

Einen Kommentar hinterlassen

Deine E-Mail-Adresse wird nicht veröffentlicht.


*


− 3 = 5

Durch die weitere Nutzung der Seite stimmst du der Verwendung von Cookies zu. Weitere Informationen

Die Cookie-Einstellungen auf dieser Website sind auf "Cookies zulassen" eingestellt, um das beste Surferlebnis zu ermöglichen. Wenn du diese Website ohne Änderung der Cookie-Einstellungen verwendest oder auf "Akzeptieren" klickst, erklärst du sich damit einverstanden.

Schließen